FEATURES folder does not exist in folder structure

Jan 19, 2010 at 8:04 AM

Hi It tried to add some more lists to an existing .spsource file in a project that once worked, but when I try to run SPSource it gives me the exception saying "FEATURES folder does not exist in folder structure". This is definitely not true. A screenshot may be found here: http://cid-18a877dfc11bb281.skydrive.live.com/self.aspx/Screen/spsource%5E_error.png

Jan 19, 2010 at 8:13 AM

How are you calling SPSource.exe ? Can you post what command line you are executing and from where you are executing it from?

Jan 19, 2010 at 8:16 AM
Edited Jan 19, 2010 at 8:17 AM

From the Tools menu, where the external tool is configured for command line "C:\Program Files\SPSource\SPSource.exe" -d http://spdev. Output window is used as you may see in the screenshot. Locally on the server.

Jan 19, 2010 at 8:19 AM
Edited Jan 19, 2010 at 8:19 AM

What I could think of as a reason for that is the LoopbackCheck which I don't remember having disabled. Will try from a remote machine. If that's the reason, then the exception may be handled inappropriately.

Jan 19, 2010 at 8:38 AM

OK, it's nothing to do with the loopback check. When you do the external tools, have you got the WSPBuilder Project selected in the Solution explorer?

Jan 19, 2010 at 8:40 AM
Edited Jan 19, 2010 at 8:43 AM

The .spsource itself was selected. I tried again with the WSPBuilder Project highlighted in the Solution Explorer. To no avail.

This is a dummy solution with the one and only Project Generated from WSP Builder.

Jan 19, 2010 at 8:41 AM

Can you open up a command prompt and navigate to the root o fthe WSPBuilder project directory and run the SPSource with the argument from there? Just want to elimiate that.

Jan 19, 2010 at 8:44 AM

C:\WINDOWS\system32>cd \projects\air

C:\Projects\Air>"c:\Program Files\SPSource\SPSource.exe" -d http://spdev

---------------------------------------------
Lists.spsource
---------------------------------------------
Found .spsource file: C:\Projects\Air\12\TEMPLATE\FEATURES\AirLists\Lists.spsource

---------------------------------------------
Completed
---------------------------------------------
SPSource Completed

C:\Projects\Air>

Jan 19, 2010 at 8:45 AM

No new items were added to the project

Jan 19, 2010 at 8:46 AM

OK so SPSource is running correctly now. What's in your .spsource file. can you put that in here? It's not finding anything in the file XML wise that it is parsing.

Jan 19, 2010 at 8:50 AM
<?xml version="1.0" encoding="utf-8"?>
<Elements xmlns="http://schemas.microsoft.com/sharepoint/">
  <!--These have been reverse engineered in December-->
  <ListInstance Title="Svc"/>
  <ListInstance Title="Firm"/>
  <ListInstance Title="Pay"/>
  <ListInstance Title="Def"/>
  <!--These I try to reverse engineer today-->
  <ListInstance Title="RoleDefinitionBindings"/>
  <ListInstance Title="DecisionMakers"/>
  <ListInstance Title="Deputies"/>
</Elements>
Jan 19, 2010 at 8:51 AM
Edited Jan 19, 2010 at 8:53 AM

oops, ListTemplate again... Works now. Sorry. But still what's wrong with the external tool call?

Jan 19, 2010 at 8:52 AM

OK, if you take a look at the latest release and also look at the documentation you'll see that you have to use <ListTemplate> not <ListInstance> in the .spsource files.

Jan 19, 2010 at 8:53 AM

But still what's wrong with the external tool call?

Jan 19, 2010 at 8:55 AM

Have you got a starting directory value in there...looks like it's calling it with wrong context e.g. where it executes SPSource.exe from. Cut and paste me the values for each setting for the External Tool you've added.

Jan 19, 2010 at 8:56 AM

Yep, found it. Thanks. Case closed.