SPSource and Custom List Forms

Nov 11, 2009 at 12:41 PM

Hi

I have created a custom list form ( TrainingCourse.aspx ) for example.  The site works fine.  I know want to package the functionality up into a feature.  I tried to us SPSource however the new page was not added to the feature.  Is what I am trying to do possible, if so could you point me in the right direction please.

Thanks in advance
pmatthe1

Nov 14, 2009 at 7:09 AM

I take it you've gone through the howto documentation?

Does it create the trainingcourse.aspx file in the List Template folder within the feature folder? And add this file to the feature manifest xml?

Is it when you activate the feature that the new page is not hooked up correctly? does the page get deployed and can you access it?

You can attach the solution package visual studio project as a zip which would help me to guide you further too if you wish.

Cheers,

Jeremy

Nov 25, 2009 at 3:22 AM

pmatthew1, 

make sure in the schema.xml that the SetupPath parameter is removed, if its there, it will use the default form and not the one existing in your folder.

<Form Type="EditForm" Url="TrainingCourse.aspx" WebPartZoneID="Main" />

Nov 27, 2009 at 12:18 AM

@pmatthe1 - did you manage to see what SPSource was generating based on @walshiau's suggestion? is it doing the right thing?

Dec 9, 2009 at 7:40 PM

Hi,

I am having the same problem, I think. SPSource correctly generates schema.xml and allitems.aspx,dispform.aspx, editform.aspx and newform.aspx, however it doesn't retrieve my custom new form - newFormCRPU.aspx in this case. 

 

Dec 10, 2009 at 11:59 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.