SPSource Starter Guide WSPBuilder

May 29, 2009 at 12:15 AM

Hi, first of all, thanks for creating and sharing such a great tool with the community.

I am trying to follow the documentation you provided but once I try to add a new feature into the project ( the "Create New Feature" step) - VS 2008 just crashes and this error is logged in event viewer:

 Event Type: Error
Event Source: .NET Runtime
Event Category: None
Event ID: 1023
Date:  5/28/2009
Time:  4:55:31 PM
User:  N/A
Computer: 
Description:
.NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (7A097706) (80131506)

Any ideas what may cause this?

May 29, 2009 at 1:22 AM

This sounds like an issue with 3.5 SP1. Try uninstall SP1 to confirm the cause.

May 29, 2009 at 1:36 AM

Thanks for helping JefferyTsui.

+1 on 3.5 SP1 install. It's the .NET Framework having an issue here.

May 29, 2009 at 3:45 AM
Thanks for the quick reply everyone. I did try uninstall .Net 3.5 sp1
but the issue remained. Can I workaround this step by manually
creating the feature folders in VS2008? thanks.
On 5/28/09, jthake <notifications@codeplex.com> wrote:
> From: jthake
>
> Thanks for helping JefferyTsui.+1 on 3.5 SP1 install. It's the .NET
> Framework having an issue here.
>
>
May 29, 2009 at 11:48 PM

I'm sure you've already used Google to search for the error, but have you seen this:

http://support.microsoft.com/kb/824210

Jun 2, 2009 at 7:51 PM

Thanks jthake, I tried downloading and installing it in my environment but got this message:

---------------------------
KB824210 Setup Error
---------------------------
Setup has detected that the Service Pack version of the system installed
is newer than the update you are applying to it.

You can only install this update on a computer with no Service Packs installed.

Jun 2, 2009 at 9:00 PM

hi, clearing all the .net temp folders resolved this issue. thanks for everyone's help.