Unable to get SPSource to connect to my Site

Mar 4, 2010 at 3:01 PM

Hello,

I am a new SPSource user and new to SharePoint.  I have created features and simple 'Hello World' site pages etc in a WSP, time to move onto custom content types etc.  I tried to use SPSource to get my own list template and content type but kept getting an error so I thought I would work through the user guide example and see if it worked.  Nope, same error.

The exception I get is:  (other than the spsource file name in VS the items match user guide - Documents/Demo Document etc)

Found .spsource file: C:\Users\jeff\Documents\Visual Studio 2008\Projects\HPCIntegration\HPCIntegration\12\TEMPLATE\FEATURES\HPCIntegrationAdmin\HPCScheduledTime.spsource
ERROR: System.IO.FileNotFoundException: The Web application at http://sp-2007.vmservers.local/sites/design/ could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.
   at Microsoft.SharePoint.SPSite..ctor(SPFarm farm, Uri requestUri, Boolean contextSite, SPUserToken userToken)
   at Microsoft.SharePoint.SPSite..ctor(String requestUrl)
   at SPSource.Lists.ListUtility.ListExists(String listName, String webUrl)
   at SPSource.Lists.ListManager.GetList(XmlNode listTemplate)

I have tried everything for the --DesignSite parameter to the server.  I have tried fully defined name with domain (see above) or just the servername or localhost.  Always the same issue.  I am running SPSource from on the server where SharePoint is.    In my browser if I go to http://sp-2007/sites/design/Lists/Documents/AllItems.aspx I see the Documents list and it works with my custom Content Type.

I have yet to try other code to use SPSite to get a connection to my site to make sure that is working.  Going to do that next but thought I would see if others hand an idea in the meanwhile.

Thanks, Jeff

Mar 4, 2010 at 5:33 PM

Maybe someone can confirm or deny what I think is happening.

 

My SP server is 64-bit and my SPSource seems to be 32-bit.  Would this cause the issue??

 

Thanks, Jeff